Archiv der Kategorie: SCCM

Bitlocker verhindert das Booten unter Windows 7 nach Deployment mit ConfigMgr Current Branch

Bei der Aktualisierung von SCCM wird auch immer das Bootimage aktualisiert auf die neueste Version. Wenn man im Unternehmen damit aber auch weiterhin Windows 7 deployed und mit Bitlocker die Festplatten verschlüsselt taucht folgende Fehlermeldung nach der Installation des Betriebssystems auf:

FILE: \WINDOWS\system32\winload.exe

Status: 0xc210000

Info: The action could not be completed because the Bitlocker Drive Encryption key required to unlock the volume could not be obtained.

Hört sich erstmal ganz schlimm an, ist es aber nicht. Zum Hintergrund muss man verstehen, dass die Bitlocker Verschlüsselungsroutinen sich mit Windows 10 ändern. Die neue Verschlüsselungsroutine XTS-AES kann nicht von Windows 7 gelesen werden und daher kommt es zu dieser Fehlermeldung.

Das betroffene Bootimage ist das was beim Upgrade von v1511 auf die nächste Version aktualisiert wird.

Um das Deployment zu reparieren muss die Tasksequenz angepackt werden.
Hier müssen vor dem Step Pre-Provision Bitlocker drei Registrykeys gesetzt werden:

reg add HKLM\SOFTWARE\Policies\Microsoft\FVE /t REG_DWORD /v EncryptionMethodWithXtsFdv /d 3 /f
reg add HKLM\SOFTWARE\Policies\Microsoft\FVE /t REG_DWORD /v EncryptionMethodWithXtsOs /d 3 /f
reg add HKLM\SOFTWARE\Policies\Microsoft\FVE /t REG_DWORD /v EncryptionMethodWithXtsRdv /d 3 /f

Damit bringt man dem Bootimage bei, dass AES-CBC 128bit benutzt werden soll das von Windows 7 verstanden wird.

Die Keys müssen gesetzt werden bevor Bitlocker Pre-Provisioning passiert:

Die Schritte in der Tasksequenz sind vom Typ General -> Run Command Line :

Die Values stehen dabei für folgende Verschlüsselungsroutinen:
3 = AES-CBC 128-bit
4 = AES-CBC 256-bit
6 = XTS-AES 128-bit
7 = XTS-AES 256-bit

Update Rollup 4 für System Center 2012R2

Microsoft hat das Update Rollup 4 für die System Center 2012 R2 Familie veröffentlicht.

Dem UR4 für DPM 2012R2 hat ich einen separaten Blogeintrag gewidmet unter:
http://www.dpmpro.de/update-rollup-4-fuer-dpm-2012r2/

Wer in SCSM Probleme damit hat, dass seine Konsole abschmiert wenn man Knowledge Einträge bearbeitet und diese mit Apply speichern will, der sollte unbedingt das UR4 installieren. Dieser Bug ist damit gelöst.

UR4 ist via WSUS verfügbar oder als direkter Download bei den entsprechenden KB Artikeln für die jeweiligen Komponenten von System Center:
http://support.microsoft.com/kb/2992012

Zeitgleich ist übrigens das Update Rollup 8 für die Nutzer von 2012 SP1 erschienen:
http://support.microsoft.com/kb/2991990

CU2 für SCCM 2012R2

Wer mit ständigen Abstürzen des SMS Executive Dienstes in seinem Environment zu kämpfen hat, darf sich freuen. Das CU2 für System Center Configuration Manager 2012R2 ist erschienen und fixt dieses Problem.

Darüber hinaus löst es eine Reihe anderer Probleme. Allerdings warnt Microsoft ausdrücklich vor der Installation dieses CU wenn man KEINES der beschriebenen Probleme hat.

Also bitte dieses Update nicht einfach so approven und installieren.
Vorher sorgfältigst den KB Artikel lesen hier.

Warning: Matching Processor Architecture Boot Image (0) not found

Ich hatte bei einem SCCM Distribution Point im Ausland bei einem Kunden heute das Problem, dass beim PXE Boot zum Installieren eines neuen Client Devices nichts vorangeht. Ein Blick in die SMSPXE.LOG unter \SMS_DP$\sms\logs\ lieferte die Warnung:

Warning: Matching Processor Architecture Boot Image (0) not found

Es stellte sich heraus, dass kein x86 Boot Image auf dem Distribution Point war. Der Kunde brauchte in dieser Niederlassung ausschließlich x64 Images und entschied sich bewusst keine x86 Images dahin zu replizieren.

Leider mag SCCM 2012 das gar nicht. Wenn kein x86 Image gefunden wird, geht es nicht weiter.

Also immer darauf achten, dass für beide Architekturen ein Image auf dem Distribution Point vorhanden ist.

SCCM 2012 SP1: Neuen Bericht erstellen schlägt mit Fehlermeldung fehl: Report Builder-ClickOnce Anwendung ist auf dem Berichtsserver nicht vorhanden

Bei einem Kunden hatte ich nach dem Upgrade von SCCM 2012 auf die SP1 Variante das Problem, dass eigene Reports nicht mehr erstellt werden konnten.

Es kam die Fehlermeldung: Die Report Builder-ClickOnce Anwendung ist auf dem Berichtsserver nicht vorhanden. Stellen Sie sicher, dass das Anwendungsmanifest für Report Builder auf dem Server vorhanden ist, und wiederholen Sie den Vorgang.

Report Builder ClickOnce fehlt

Das erste was man natürlich sicherstellen muss, ist dass der Report Builder installiert ist.
Falls dem nicht so ist, einfach hier direkt von Microsoft herunterladen und installieren.

Das alleine reicht allerdings leider nicht um es zum Laufen zu bekommen. Zusätzlich müssen ein RegistryKey & eine Konfigurationsdatei verändert werden um auf die richtige Version des Manifests zu verweisen.

Der RegistryKey der geändert werden muss findet sich unter:
HKEY_LOCAL_MACHINE -> Software -> Wow6432Node -> Microsoft -> ConfigMgr10 -> AdminUI -> Reporting

Dort findet sich ein Key namens ReportBuilderApplicationManifestName. Dieser Eintrag steht standardmässig auf ReportBuilder_2_0_0_0.application und muss geändert werden auf ReportBuilder_3_0_0_0.application damit die Reporting Services des SQL Server auch die richtige und installierte Version des Report Builder ansteuern können.

Das Bearbeiten der Konfigurationsdatei ist ähnlich. Die Konfigurationsdatei heisst Microsoft.ConfigurationManagement.exe.config und findet sich unter C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\bin\ .
Die Datei enthält nur Text und kann daher mit einem beliebigen Texteditor editiert werden.

Hat man SCCM in einen anderen Pfad installiert sucht man entsprechend in diesem Pfad.

In dieser Konfigurationsdatei findet sich ein Abschnitt namens <ReportBuilderMapping>.
Die ersten zwei Einträge verweisen korrekt auf die 3er Version aber die nächsten zwei auf die 2er Version:

<ReportBuilderMapping>
<add key=“11.0″ value=“ReportBuilder_3_0_0_0.application“/>
<add key=“10.50″ value=“ReportBuilder_3_0_0_0.application“ />
<add key=“10.0″ value=“ReportBuilder_2_0_0_0.application“/>
<add key=“DEFAULT“ value=“ReportBuilder_2_0_0_0.application“/>
</ReportBuilderMapping>

Hier also die beiden letzteren Einträge ebenfalls auf ReportBuilder_3_0_0_0.application ändern und die Datei abspeichern.

Jetzt lassen sich dann wieder erfolgreich eigene Reports erstellen in SCCM 2012 SP1.

Fehler 0x80004005 bei Tasksequenz nach Update von SCCM 2012 auf SCCM 2012 SP1

Das Upgrade für System Center Configuration Manager 2012 auf SP1 hat diverse Fallstricke. Eines davon hat mich bei einem Kunden überrascht. Unbeaufsichtige Installationen die vor dem Upgrade einwandfrei funktioniert haben, tun es plötzlich nicht mehr. Sie bleiben nach der Installation der Treiber und vor der Installation des SCCM Clients hängen mit dem Fehler 0x80004005:

SCCM 2012 SP1 Fehler bei Tasksequenz 0x80004005

Das Imageupgrade war erfolgt und das Image hat vor dem Update einwandfrei funktioniert.
Nachdem das smsts.log keine weiterführenden Erkenntnisse gebracht hat führte eine Recherche zu diesem Hotfix von Microsoft: KB2801987

Die Installation dieses Hotfixes auf dem SCCM Server hat das Problem für die meisten Images gelöst. Diese laufen nun wieder einwandfrei durch. Bei einem Image hingegen scheint es tatsächlich eine Inkompatibilität zu geben was Treiber und neues Bootimage anbetrifft.