Schlagwort-Archive: Error 0x80004005

McAfee und Windows Server 2012R2 Deduplication

Es gibt ein bekanntes Problem bei der Zusammenarbeit von McAfee VirusScan Enterprise (VSE) 8.8 und höher mit der Datendeduplizierung von Windows Server 2012R2.

XP Clients die auf File Shares zugreifen, die auf einem deduplizierten Windows Server 2012R2 Volume liegen laufen in Fehlermeldungen. Die häufigste Meldung dabei lautet:

The Request is not supported.

Ich habe diesen Fehler gesehen bei PDFs, Worddateien, Exceldateien und auch bei Executables. Der genaue Wortlaut variiert dabei leicht.

Ursache für dieses Problem ist ein Registry Eintrag der von der Installation von McAfee VirusScan Enterprise gesetzt wird. Eine Deinstallation von McAfee entfernt diesen Registry Key nicht!

Man muss ihn daher selbst deaktivieren.

Dabei muss man den Key enableecp unter HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters\ auf 0x0 setzen. Anschließend ist ein Reboot des Servers oder ein Restart des Server Service notwendig mit Hilfe von NET STOP SERVER && NET START SERVER.

Danach ist der Fehler weg.

Es gibt einen KB Artikel von Microsoft dazu und auch von McAfee:

http://support.microsoft.com/kb/2817216

https://kc.mcafee.com/corporate/index?page=content&id=KB77623

Fehler 0x80004005 bei Tasksequenz nach Update von SCCM 2012 auf SCCM 2012 SP1

Das Upgrade für System Center Configuration Manager 2012 auf SP1 hat diverse Fallstricke. Eines davon hat mich bei einem Kunden überrascht. Unbeaufsichtige Installationen die vor dem Upgrade einwandfrei funktioniert haben, tun es plötzlich nicht mehr. Sie bleiben nach der Installation der Treiber und vor der Installation des SCCM Clients hängen mit dem Fehler 0x80004005:

SCCM 2012 SP1 Fehler bei Tasksequenz 0x80004005

Das Imageupgrade war erfolgt und das Image hat vor dem Update einwandfrei funktioniert.
Nachdem das smsts.log keine weiterführenden Erkenntnisse gebracht hat führte eine Recherche zu diesem Hotfix von Microsoft: KB2801987

Die Installation dieses Hotfixes auf dem SCCM Server hat das Problem für die meisten Images gelöst. Diese laufen nun wieder einwandfrei durch. Bei einem Image hingegen scheint es tatsächlich eine Inkompatibilität zu geben was Treiber und neues Bootimage anbetrifft.